3.0.1

     Apple recently released iPhone 3.0.1 firmware, fixing SMS issues. When it comes to iPhone firmwares, most of us know the Dev-Team hops onto jailbreaking them as soon as they can. Well, it turns out that the Dev-Team didn’t even have the chance to jailbreak firmware 3.0.1. This is because 3.0.1 is compatible with the latest Redsn0w jailbreak without any Dev-Team tampering. The Dev-Team tells us that you can re-use Redsn0w v0.8 as long as you point Redsn0w to the 3.0 IPSW after you’ve updated to 3.0.1 via iTunes. And, for those of you who want to unlock you iPhone, Ultrasn0w 0.9 is compatible with 3.0.1 since the baseband wasn’t touched in this software update.

     The Dev-Team gives us the reason for Redsn0w compatibility with 3.0.1. Apparently 3.0.1 is just a branch from 3.0. Since 3.0.1 fixes just the SMS bug, and Redsn0w doesn’t touch that, the only things Redsn0w touches remain the same in 3.0.1 as in 3.0. The Dev-Team states that they will soon implement recognition of 3.0.1 as well for Redsn0w. However, until then, we are told there is no reason to wait for 3.0.1 recognition as there are no differences in the jailbroken 3.0 and 3.0.1 firmwares.