i have 1.1.2 and baseloader 3.9, my iphone is unlocked and jailbroken is there a way i can have 1.1.3, i keep seeing the "1.1.3 soft upgrade" things on installer,if i install this will it update my iphone to 1.1.3? and still have all the functions work…